分享你想要的

蓝揍云下载直连获取最简单版本几行代码完事

发布:影子啊2020-3-2 16:19分类: 源码资源 标签: 易语言

无密码解析只需要两行代码;
有密码只需要四行代码:
我写成了一个子程序调用,你们看吧:

直接复制粘贴就可以使用:

蓝揍云直连获取 (“https://www.lanzous.com/i1aesgj”, ) ' 无密码调用
蓝揍云直连获取 (“https://www.lanzous.com/i19pnjc”, “1pud”) ' 有密码调用

.子程序 蓝揍云直连获取, 文本型
.参数 URL, 文本型, , 蓝揍云分享链接
.参数 Passwd, 文本型, 可空, 分享密码,无密码留空
.局部变量 str, 文本型
.局部变量 sign, 文本型
.局部变量 json, 类_json
.局部变量 down_url, 文本型

str = 网页_访问S (子文本替换 (URL, “com/”, “com/tp/”, , , 假), , , , , “User-Agent: Mozilla/5.0 (Linux; U; Android 8.1.0; zh-cn; BLA-AL00 Build/HUAWEIBLA-AL00) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/57.0.2987.132 MQQBrowser/8.9 Mobile Safari/537.36”, , , , , , , , , , , , , , , )
.如果 (是否为空 (Passwd))
    down_url = 文本_取出中间文本 (str, “urlpt = '”, “'”, , ) + 文本_取出中间文本 (str, “sgo = '”, “'”, , )
.否则
    sign = 文本_取出中间文本 (str, “sign=”, “&”, , )
    str = 网页_访问S (“https://www.lanzous.com/ajaxm.php”, 1, “action=downprocess&sign=” + sign + “&p=” + Passwd, , , “Referer: ” + URL, , , , , , , , , , , , , , , )
    json.解析 (str)
    down_url = json.取通用属性 (“dom”, ) + “/file/” + json.取通用属性 (“url”, )
.如果结束
返回 (down_url)

温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!

已有 0/548 人参与

发表评论:

欢迎分享亦友网

欢迎使用手机扫描访问本站,还可以关注微信哦~